This patch improves code readability by changing the following construct:

>    if (cond)
>        goto passive;
>    foo();
>    goto out;
>passive:
>    bar();
>out:

into this:

>    if (cond)
>        bar();
>    else
>        foo();

Signed-off-by: Artur Świgoń <a.swi...@partner.samsung.com>
---
 drivers/devfreq/exynos-bus.c | 24 +++++++++---------------
 1 file changed, 9 insertions(+), 15 deletions(-)

diff --git a/drivers/devfreq/exynos-bus.c b/drivers/devfreq/exynos-bus.c
index cf6f6cbd0f55..4bb83b945bf7 100644
--- a/drivers/devfreq/exynos-bus.c
+++ b/drivers/devfreq/exynos-bus.c
@@ -505,25 +505,19 @@ static int exynos_bus_probe(struct platform_device *pdev)
        node = of_parse_phandle(dev->of_node, "devfreq", 0);
        if (node) {
                of_node_put(node);
-               goto passive;
+               ret = exynos_bus_profile_init_passive(bus, profile);
+               if (ret < 0)
+                       goto err;
        } else {
                ret = exynos_bus_parent_parse_of(np, bus);
+               if (ret < 0)
+                       goto err;
+
+               ret = exynos_bus_profile_init(bus, profile);
+               if (ret < 0)
+                       goto err;
        }
 
-       if (ret < 0)
-               goto err;
-
-       ret = exynos_bus_profile_init(bus, profile);
-       if (ret < 0)
-               goto err;
-
-       goto out;
-passive:
-       ret = exynos_bus_profile_init_passive(bus, profile);
-       if (ret < 0)
-               goto err;
-
-out:
        max_state = bus->devfreq->profile->max_state;
        min_freq = (bus->devfreq->profile->freq_table[0] / 1000);
        max_freq = (bus->devfreq->profile->freq_table[max_state - 1] / 1000);
-- 
2.17.1

Reply via email to