Make use of the swap macro and remove unnecessary variable *tmp_mem*.
This makes the code easier to read and maintain. Also, reduces the
stack usage.

This code was detected with the help of Coccinelle.

Signed-off-by: Gustavo A. R. Silva <gust...@embeddedor.com>
---
 drivers/gpu/drm/ttm/ttm_bo.c | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)

diff --git a/drivers/gpu/drm/ttm/ttm_bo.c b/drivers/gpu/drm/ttm/ttm_bo.c
index 5d8688e52..5142dcb 100644
--- a/drivers/gpu/drm/ttm/ttm_bo.c
+++ b/drivers/gpu/drm/ttm/ttm_bo.c
@@ -287,12 +287,9 @@ static int ttm_bo_handle_move_mem(struct ttm_buffer_object 
*bo,
 
        if (ret) {
                if (bdev->driver->move_notify) {
-                       struct ttm_mem_reg tmp_mem = *mem;
-                       *mem = bo->mem;
-                       bo->mem = tmp_mem;
+                       swap(*mem, bo->mem);
                        bdev->driver->move_notify(bo, false, mem);
-                       bo->mem = *mem;
-                       *mem = tmp_mem;
+                       swap(*mem, bo->mem);
                }
 
                goto out_err;
-- 
2.7.4

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

Reply via email to