Op 28-11-16 om 13:20 schreef Nicolai Hähnle: > From: Nicolai Hähnle <Nicolai.Haehnle at amd.com> > > Cc: Peter Zijlstra <peterz at infradead.org> > Cc: Ingo Molnar <mingo at redhat.com> > Cc: Maarten Lankhorst <dev at mblankhorst.nl> > Cc: Daniel Vetter <daniel at ffwll.ch> > Cc: Chris Wilson <chris at chris-wilson.co.uk> > Cc: dri-devel at lists.freedesktop.org > Signed-off-by: Nicolai Hähnle <Nicolai.Haehnle at amd.com> > --- > drivers/gpu/drm/vgem/vgem_fence.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/gpu/drm/vgem/vgem_fence.c > b/drivers/gpu/drm/vgem/vgem_fence.c > index 488909a..e1d516f 100644 > --- a/drivers/gpu/drm/vgem/vgem_fence.c > +++ b/drivers/gpu/drm/vgem/vgem_fence.c > @@ -191,12 +191,12 @@ int vgem_fence_attach_ioctl(struct drm_device *dev, > > /* Expose the fence via the dma-buf */ > ret = 0; > - mutex_lock(&resv->lock.base); > + ww_mutex_lock(&resv->lock.base, NULL); Yuck, can we rename base to __NEVER_TOUCH_DIRECTLY_OUTSIDE_LOCKING_CORE? It's harder to get them confused like that, even with a null context it's illegal to call mutex_lock/unlock directly.
~Maarten