From: Ville Syrjälä <ville.syrj...@linux.intel.com>

Use max() to make the code to determine the allocation size for
the ioctl data easier to read.

Signed-off-by: Ville Syrjälä <ville.syrjala at linux.intel.com>
---
 drivers/gpu/drm/drm_ioctl.c | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/drivers/gpu/drm/drm_ioctl.c b/drivers/gpu/drm/drm_ioctl.c
index 68ba014..4a2bf2b 100644
--- a/drivers/gpu/drm/drm_ioctl.c
+++ b/drivers/gpu/drm/drm_ioctl.c
@@ -683,9 +683,8 @@ long drm_ioctl(struct file *filp,
        }

        drv_size = _IOC_SIZE(ioctl->cmd);
-       usize = asize = _IOC_SIZE(cmd);
-       if (drv_size > asize)
-               asize = drv_size;
+       usize = _IOC_SIZE(cmd);
+       asize = max(usize, drv_size);
        cmd = ioctl->cmd;

        DRM_DEBUG("pid=%d, dev=0x%lx, auth=%d, %s\n",
-- 
2.0.5

Reply via email to