Rename hdmi_infoframe to exynos_hdmi_infoframe to avoid nameing
collision.

Signed-off-by: Sean Paul <seanpaul at chromium.org>
---

Changes in v4:
 - Added

 drivers/gpu/drm/exynos/exynos_hdmi.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/gpu/drm/exynos/exynos_hdmi.c 
b/drivers/gpu/drm/exynos/exynos_hdmi.c
index a0e10ae..e1c1bfc 100644
--- a/drivers/gpu/drm/exynos/exynos_hdmi.c
+++ b/drivers/gpu/drm/exynos/exynos_hdmi.c
@@ -379,7 +379,7 @@ static const struct hdmiphy_config hdmiphy_v14_configs[] = {
        },
 };

-struct hdmi_infoframe {
+struct exynos_hdmi_infoframe {
        enum HDMI_PACKET_TYPE type;
        u8 ver;
        u8 len;
@@ -682,7 +682,7 @@ static u8 hdmi_chksum(struct hdmi_context *hdata,
 }

 static void hdmi_reg_infoframe(struct hdmi_context *hdata,
-                       struct hdmi_infoframe *infoframe)
+                       struct exynos_hdmi_infoframe *infoframe)
 {
        u32 hdr_sum;
        u8 chksum;
@@ -985,7 +985,7 @@ static void hdmi_conf_reset(struct hdmi_context *hdata)

 static void hdmi_conf_init(struct hdmi_context *hdata)
 {
-       struct hdmi_infoframe infoframe;
+       struct exynos_hdmi_infoframe infoframe;

        /* disable HPD interrupts from HDMI IP block, use GPIO instead */
        hdmi_reg_writemask(hdata, HDMI_INTC_CON, 0, HDMI_INTC_EN_GLOBAL |
-- 
1.8.5.1

Reply via email to