On Feb 21, 9:43 am, Russell Keith-Magee <freakboy3...@gmail.com> wrote: > It sounds like what you actually want to write is one long test, > rather than N order dependent short tests. If you want to break things > into methods for the sake of clarity/code organization, you can - just > break the test_* entry method into smaller parts: > > class MyTest(TestCase): > > def test_long_test(self): > self._part1() > self._part2() > ... > self._partN() > > def _part1(self):
Got it. Thanks, that is exactly what I need to do in a couple of cases. Won't be really long tests, just 2 parts per. -- You received this message because you are subscribed to the Google Groups "Django users" group. To post to this group, send email to django-us...@googlegroups.com. To unsubscribe from this group, send email to django-users+unsubscr...@googlegroups.com. For more options, visit this group at http://groups.google.com/group/django-users?hl=en.