On 01/20/2010 08:41 PM, Daniel Roseman wrote: > On Jan 20, 7:09 pm, Olivier Guilyardi <m...@xung.org> wrote: >> For best performances, should I: >> >> records = MyModel.objects.all() >> for item in records: >> ... >> >> or is the following ok: >> >> for item in MyModel.objects.all(): >> ... >> >> ? > > There is no difference, except for the infinitesimal amount of time > for the extra variable lookup. The only difference is readability, or > if you need to use the same queryset again.
Thanks! -- Olivier
-- You received this message because you are subscribed to the Google Groups "Django users" group. To post to this group, send email to django-us...@googlegroups.com. To unsubscribe from this group, send email to django-users+unsubscr...@googlegroups.com. For more options, visit this group at http://groups.google.com/group/django-users?hl=en.