On Wed, Jul 16, 2008 at 11:01 AM, Marty Alchin <[EMAIL PROTECTED]> wrote: > Of course, you're welcome to go with Scott's suggestion of doing all > the math in one line, but it loses a bit readability going that way. > On the flip side, it probably executes slightly faster, but probably > not enough to make much different in the real world.
Faster and more readable (imho): >>> def make_divisible_by_4(num): ... div, mod = divmod(num, 4) ... return mod and (div + 1) * 4 or num ... >>> make_divisible_by_4(8) 8 >>> make_divisible_by_4(10) 12 >>> make_divisible_by_4(33) 36 Arien --~--~---------~--~----~------------~-------~--~----~ You received this message because you are subscribed to the Google Groups "Django users" group. To post to this group, send email to django-users@googlegroups.com To unsubscribe from this group, send email to [EMAIL PROTECTED] For more options, visit this group at http://groups.google.com/group/django-users?hl=en -~----------~----~----~----~------~----~------~--~---