#32178: Allow database backends to skip tests and mark expected failures
-------------------------------------+-------------------------------------
Reporter: Tim Graham | Owner: Hasan
| Ramezani
Type: New feature | Status: closed
Component: Database layer | Version: master
(models, ORM) |
Severity: Normal | Resolution: fixed
Keywords: | Triage Stage: Ready for
| checkin
Has patch: 1 | Needs documentation: 0
Needs tests: 0 | Patch needs improvement: 0
Easy pickings: 0 | UI/UX: 0
-------------------------------------+-------------------------------------
Comment (by Chris Jerdonek):
I have a comment / question about this feature. I was analyzing a test by
inspecting the code, and I couldn't figure out why it was passing on
SQLite because it used to have "skip" code which is no longer there. And
then I came across this ticket via the history.
Would it be possible to have at least a code convention of including a
code comment at the test site when the test is included in
`django_test_skips`? Otherwise, the average reader wouldn't know to check
there for the test's name. (I would call this behavior "magical" because
it's not explicit at the code site.) Also, even for people that know about
it, it's not something that's easy to check while e.g. browsing the code
on the web.
--
Ticket URL: <https://code.djangoproject.com/ticket/32178#comment:14>
Django <https://code.djangoproject.com/>
The Web framework for perfectionists with deadlines.
--
You received this message because you are subscribed to the Google Groups
"Django updates" group.
To unsubscribe from this group and stop receiving emails from it, send an email
to [email protected].
To view this discussion on the web visit
https://groups.google.com/d/msgid/django-updates/067.9e353f182b2f04427e6efd45446e030b%40djangoproject.com.