#31280: Rename DEBUG_PROPAGATE_EXCEPTIONS to PROPAGATE_EXCEPTIONS
-------------------------------------------------+------------------------
               Reporter:  Adam (Chainz) Johnson  |          Owner:  nobody
                   Type:  Cleanup/optimization   |         Status:  new
              Component:  HTTP handling          |        Version:  master
               Severity:  Normal                 |       Keywords:
           Triage Stage:  Unreviewed             |      Has patch:  0
    Needs documentation:  0                      |    Needs tests:  0
Patch needs improvement:  0                      |  Easy pickings:  0
                  UI/UX:  0                      |
-------------------------------------------------+------------------------
 The rarely needed setting `DEBUG_PROPAGATE_EXCEPTIONS` is confusingly
 named. It applies all the time, not just when `DEBUG = True`.

 I propose renaming it to `PROPAGATE_EXCEPTIONS` with the standard
 deprecation period.

-- 
Ticket URL: <https://code.djangoproject.com/ticket/31280>
Django <https://code.djangoproject.com/>
The Web framework for perfectionists with deadlines.

-- 
You received this message because you are subscribed to the Google Groups 
"Django updates" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To view this discussion on the web visit 
https://groups.google.com/d/msgid/django-updates/053.460d1b38d8580db010f3bf4ff592f0a3%40djangoproject.com.

Reply via email to