#29900: ForeignKey foo with to_field=bar option: Accessor should be called 
foo_bar
not foo_id
-------------------------------------+-------------------------------------
     Reporter:  Paul Zeinlinger      |                    Owner:  nobody
         Type:                       |                   Status:  closed
  Cleanup/optimization               |
    Component:  Database layer       |                  Version:  2.1
  (models, ORM)                      |
     Severity:  Normal               |               Resolution:  wontfix
     Keywords:  to_field             |             Triage Stage:
                                     |  Unreviewed
    Has patch:  0                    |      Needs documentation:  0
  Needs tests:  0                    |  Patch needs improvement:  0
Easy pickings:  0                    |                    UI/UX:  0
-------------------------------------+-------------------------------------
Changes (by Tim Graham):

 * status:  new => closed
 * resolution:   => wontfix


Comment:

 I guess this would have to be discussed on the DevelopersMailingList to
 see if there's consensus to go through the hassle of changing the accessor
 name. My guess is that it would cause more trouble than it's worth at this
 point.

 A related ticket is #11265, "ForeignKey/OneToOneField should support user-
 defined id attribute name".

-- 
Ticket URL: <https://code.djangoproject.com/ticket/29900#comment:3>
Django <https://code.djangoproject.com/>
The Web framework for perfectionists with deadlines.

-- 
You received this message because you are subscribed to the Google Groups 
"Django updates" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit 
https://groups.google.com/d/msgid/django-updates/069.2cda8c4b6cdda867afe9f5652582054c%40djangoproject.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to