#29248: Model field names can conflict with admin's field-box CSS class
-------------------------------+------------------------------------
     Reporter:  Phil Gyford    |                    Owner:  faheel
         Type:  Bug            |                   Status:  assigned
    Component:  contrib.admin  |                  Version:  2.0
     Severity:  Normal         |               Resolution:
     Keywords:                 |             Triage Stage:  Accepted
    Has patch:  0              |      Needs documentation:  0
  Needs tests:  0              |  Patch needs improvement:  0
Easy pickings:  1              |                    UI/UX:  0
-------------------------------+------------------------------------
Changes (by faheel):

 * owner:  nobody => faheel
 * status:  new => assigned


Comment:

 It does seem like `field-box` is the only potentially conflicting class in
 `forms.css` as no other class starts with `field-`. My suggestion is to
 rename it to either `fieldbox` or `field__box` (this one is based on the
 [https://en.bem.info/methodology/quick-start/ BEM methodology]).

-- 
Ticket URL: <https://code.djangoproject.com/ticket/29248#comment:2>
Django <https://code.djangoproject.com/>
The Web framework for perfectionists with deadlines.

-- 
You received this message because you are subscribed to the Google Groups 
"Django updates" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit 
https://groups.google.com/d/msgid/django-updates/068.b86707ab14bc8519182e517dcca3b821%40djangoproject.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to