#28690: django.utils.http.parse_http_date two digit year check is incorrect
-----------------------------------------+------------------------
               Reporter:  Mads Jensen    |          Owner:  nobody
                   Type:  Bug            |         Status:  new
              Component:  Uncategorized  |        Version:  master
               Severity:  Normal         |       Keywords:
           Triage Stage:  Unreviewed     |      Has patch:  0
    Needs documentation:  0              |    Needs tests:  0
Patch needs improvement:  0              |  Easy pickings:  1
                  UI/UX:  0              |
-----------------------------------------+------------------------
 RFC 850 does not mention this, but in RFC 7231 (and there's something
 similar in RFC 2822), there's the following quote:

    Recipients of a timestamp value in rfc850-date format, which uses a
    two-digit year, MUST interpret a timestamp that appears to be more
    than 50 years in the future as representing the most recent year in
    the past that had the same last two digits.

 The `< 70` is incorrect, and should have been `< 50`. I inserted a diff
 that applies.

-- 
Ticket URL: <https://code.djangoproject.com/ticket/28690>
Django <https://code.djangoproject.com/>
The Web framework for perfectionists with deadlines.

-- 
You received this message because you are subscribed to the Google Groups 
"Django updates" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit 
https://groups.google.com/d/msgid/django-updates/053.bd3d29012ad522ccadba505561aaf565%40djangoproject.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to