#28402: Provide 'temporary_file_path' for InMemoryUploadedFile
-------------------------------------+-------------------------------------
Reporter: Thomas Güttler | Owner: nobody
Type: | Status: new
Cleanup/optimization |
Component: File | Version: 1.11
uploads/storage |
Severity: Normal | Resolution:
Keywords: | Triage Stage:
| Unreviewed
Has patch: 0 | Needs documentation: 0
Needs tests: 0 | Patch needs improvement: 0
Easy pickings: 0 | UI/UX: 0
-------------------------------------+-------------------------------------
Comment (by Thomas Güttler):
Hi Graham, thank you for looking at this.
The code which uses `temporary_file_path` is in my code. This is no bug in
django. This is a feature request.
Yes, naming the property "temporary_file_path" could break code like this.
A new name would be needed or a clear deprecation path.
Do you understand my use case: Get a file_name (as string) which contains
the temporary upload in every case with one method.
I guess there are several hundred implementation which all do the same:
put the data from MemoryUploadedFile into a temporary file.
--
Ticket URL: <https://code.djangoproject.com/ticket/28402#comment:3>
Django <https://code.djangoproject.com/>
The Web framework for perfectionists with deadlines.
--
You received this message because you are subscribed to the Google Groups
"Django updates" group.
To unsubscribe from this group and stop receiving emails from it, send an email
to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit
https://groups.google.com/d/msgid/django-updates/065.5d5a288db67c1f126fc24de8dfd76b18%40djangoproject.com.
For more options, visit https://groups.google.com/d/optout.