#27604: Use set_signed_cookie for contrib.messages Cookie storage
------------------------------------------------+------------------------
               Reporter:  Anthony King          |          Owner:  nobody
                   Type:  Cleanup/optimization  |         Status:  new
              Component:  contrib.messages      |        Version:  master
               Severity:  Normal                |       Keywords:
           Triage Stage:  Unreviewed            |      Has patch:  0
    Needs documentation:  0                     |    Needs tests:  0
Patch needs improvement:  0                     |  Easy pickings:  0
                  UI/UX:  0                     |
------------------------------------------------+------------------------
 This relates to `django.contrib.messages.storage.cookie`.

 In its current state, the Cookie store implements it's own signing method
 (called `_hash`).
 This uses a it's own approach to verifying the data inside the cookie.

 using `set_signed_cookie` removes duplicate code, as well as allows the
 message cookie to use custom signing backends.


 There is, perhaps, another change that can be made, which is to use
 `signing.dumps` to take advantage of the zlib compression. However this
 has potential to be a breaking change for people that read the JSON in the
 cookie, and may not yield better results in size.

--
Ticket URL: <https://code.djangoproject.com/ticket/27604>
Django <https://code.djangoproject.com/>
The Web framework for perfectionists with deadlines.

-- 
You received this message because you are subscribed to the Google Groups 
"Django updates" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit 
https://groups.google.com/d/msgid/django-updates/052.2a77a22e9f4a6f9483d9cb2c22e62bad%40djangoproject.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to