#21021: Default geom_type attribute for GeometryWidget should be "Geometry", not
"Unknown"
-------------------------------------+-------------------------------------
Reporter: Mathieu Leplatre | Owner: Olivier
Type: | Tabone
Cleanup/optimization | Status: assigned
Component: GIS | Version:
| 1.6-beta-1
Severity: Normal | Resolution:
Keywords: minor | Triage Stage: Accepted
Has patch: 0 | Needs documentation: 0
Needs tests: 0 | Patch needs improvement: 0
Easy pickings: 0 | UI/UX: 0
-------------------------------------+-------------------------------------
Changes (by Olivier Tabone):
* needs_better_patch: 1 => 0
* has_patch: 1 => 0
Comment:
Looking at GDAL documentation, there is no OGR type matching 'POLYGON'.
[http://www.gdal.org/ogr__core_8h.html#a800236a0d460ef66e687b7b65610f12a
enum OGRwkbGeometryType]
Hence the '102' magic number in the patch does not match OGR
specification.
I agree with Claude we should not change OGR semantics. returning
wkbUnknown for an empty geometry seems correct according to GDAL.
removed 'has patch' flag because the pull request has been closed quite a
long time ago by tim.
--
Ticket URL: <https://code.djangoproject.com/ticket/21021#comment:7>
Django <https://code.djangoproject.com/>
The Web framework for perfectionists with deadlines.
--
You received this message because you are subscribed to the Google Groups
"Django updates" group.
To unsubscribe from this group and stop receiving emails from it, send an email
to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit
https://groups.google.com/d/msgid/django-updates/067.6915b68166a5a97ab7fae62e387a200c%40djangoproject.com.
For more options, visit https://groups.google.com/d/optout.