#26130: ModelAdmin views are too messy
--------------------------------------+--------------------
     Reporter:  yoongkang             |      Owner:  nobody
         Type:  Cleanup/optimization  |     Status:  new
    Component:  contrib.admin         |    Version:  master
     Severity:  Normal                |   Keywords:
 Triage Stage:  Unreviewed            |  Has patch:  0
Easy pickings:  0                     |      UI/UX:  0
--------------------------------------+--------------------
 ModelAdmin's views, especially changeform_view(), changelist_view() are
 long methods that are a bit hard to follow. They would benefit from some
 refactoring.

 I propose converting some of them to CBVs to make them easier to read.

--
Ticket URL: <https://code.djangoproject.com/ticket/26130>
Django <https://code.djangoproject.com/>
The Web framework for perfectionists with deadlines.

-- 
You received this message because you are subscribed to the Google Groups 
"Django updates" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit 
https://groups.google.com/d/msgid/django-updates/052.310a5c29f355e15b4addf77ef849b0fe%40djangoproject.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to