#23748: inspectdb converts auto increment primary keys into primary key
models.IntegerField() rather than primary key models.AutoField()
-------------------------------+-----------------------
Reporter: paulcdejean | Owner: nobody
Type: Uncategorized | Status: new
Component: Utilities | Version: 1.7
Severity: Normal | Keywords: inspectdb
Triage Stage: Unreviewed | Has patch: 0
Easy pickings: 0 | UI/UX: 0
-------------------------------+-----------------------
My models.py was full of stuff like:
day_id = models.IntegerField(primary_key=True)
Due to the naming convention that we prefer for our primary keys.
I actually wasn't aware of AutoField until just now, and thought that
primary keys not being made auto increment was by design for some reason.
--
Ticket URL: <https://code.djangoproject.com/ticket/23748>
Django <https://code.djangoproject.com/>
The Web framework for perfectionists with deadlines.
--
You received this message because you are subscribed to the Google Groups
"Django updates" group.
To unsubscribe from this group and stop receiving emails from it, send an email
to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit
https://groups.google.com/d/msgid/django-updates/054.b29bd66190e88390a27a7dd24dd480a9%40djangoproject.com.
For more options, visit https://groups.google.com/d/optout.