#16920: Models with GenericRelation are unnecessarily validated for clashes in
reverse manager accessor
-------------------------------------+-------------------------------------
Reporter: r1cky | Owner: nobody
Type: Bug | Status: new
Component: Database layer | Version: 1.3
(models, ORM) | Resolution:
Severity: Normal | Triage Stage: Accepted
Keywords: | Needs documentation: 0
Has patch: 1 | Patch needs improvement: 0
Needs tests: 0 | UI/UX: 0
Easy pickings: 0 |
-------------------------------------+-------------------------------------
Changes (by gabejackson):
* needs_better_patch: 1 => 0
Comment:
Clean up according to review. I'm not sure the refactor of
_check_accessor_clashes and _check_reverse_query_clashes to
_check_clashes(check_related_query_name=True/False) leads to more legible
code, but at least code duplication is now gone.
Also rebased on current master.
--
Ticket URL: <https://code.djangoproject.com/ticket/16920#comment:10>
Django <https://code.djangoproject.com/>
The Web framework for perfectionists with deadlines.
--
You received this message because you are subscribed to the Google Groups
"Django updates" group.
To unsubscribe from this group and stop receiving emails from it, send an email
to [email protected].
To post to this group, send email to [email protected].
To view this discussion on the web visit
https://groups.google.com/d/msgid/django-updates/063.b367b48e02c90e8dbea00d43243df341%40djangoproject.com.
For more options, visit https://groups.google.com/d/optout.