Hello,
I am testing LACP with OVS
* the setup is :
- Debian Wheezy with OVS from installed from official repository (V 1.4.2)
- I created a bridge xenbr0 and a bond with 2 NIC, eth0 and eth1 :
ovs-vsctl add-bond xenbr0 xenbond0 eth0 eth1 lacp=active
- The 2 NICs are connected on a Cisco Catalyst 3560 with IOS
C3560-IPBASE-M, Version 12.2(35)SE5
and the configuration is :
interface GigabitEthernet0/33
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
!
interface GigabitEthernet0/34
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
!
* I have communication over the bond, and disconnecting either nic, I
keep the connection.
* The issue is that the trafic use only 1 NIC at a time.
I initiated _several flows to differents destination_ (differents mac /
IP / subnet) and flows never split over the 2 NICs
(Yes I am aware that a single flow will use only 1 NIC, the issue is
with differents flows that all use the same NIC)
* How can I have the 2 NICs used ?
* I changed the default balance-slp mode to balance-tcp with the same
results :
ovs-vsctl set port xenbond0 bond_mode=balance-tcp
On cisco side :
Switch#show lacp 1 internal
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode
Channel group 1
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi0/33 SA bndl 32768 0x1 0x1 0x21 0x3D
Gi0/34 SA bndl 32768 0x1 0x1 0x22 0x3D
On OVS :
# ovs-vsctl show
5a4fc0c6-2c07-4257-bb7a-7a5b63be21dc
Bridge "xenbr0"
Port "vif9.0"
tag: 198
Interface "vif9.0"
Port "vif5.0"
tag: 198
Interface "vif5.0"
Port "vif30.0"
tag: 198
Interface "vif30.0"
Port "vif4.0"
tag: 198
Interface "vif4.0"
Port "xenbr0"
Interface "xenbr0"
type: internal
Port "xenbond0"
Interface "eth0"
Interface "eth1"
ovs_version: "1.4.2"
# ovs-appctl bond/show xenbond0
bond_mode: balance-tcp
bond-hash-algorithm: balance-tcp
bond-hash-basis: 0
updelay: 0 ms
downdelay: 0 ms
next rebalance: 3840 ms
lacp_negotiated: true
slave eth1: enabled
may_enable: true
slave eth0: enabled
active slave
may_enable: true
Why eth0 is active slave and not eth1?
Thank you,
Jean-François
_______________________________________________
discuss mailing list
discuss@openvswitch.org
http://openvswitch.org/mailman/listinfo/discuss