Hi, The gnuradio/math.h header is causing some problems for some out-of-tree builds that use C code. If these projects add the GNURadio includes to their build path then the system math.h header is hidden and cannot be included (this occurs, e.g., in AirProbe's gsm-receiver).
It seems bad form to define a math.h that isn't the system one so the following pull request renames math.h to math_utils.h and changes the references to the old header to the new name. Regards Steve -- The following changes since commit 54d3961bdaaa708152e33264b95759bab4d94c87: Merge branch 'master' into next (2013-11-14 12:45:59 -0500) are available in the git repository at: g...@github.com:stiabhan/gnuradio.git math-header-rename for you to fetch changes up to 7588f1875d1a932464e67b6865476619288fa8b0: gnuradio-runtime: Rename math.h to math_utils.h. (2013-11-15 14:53:06 +1000) - ---------------------------------------------------------------- Steve Glass (1): gnuradio-runtime: Rename math.h to math_utils.h. gnuradio-runtime/include/gnuradio/CMakeLists.txt | 2 +- gnuradio-runtime/include/gnuradio/{math.h => math_utils.h} | 6 +++--- gnuradio-runtime/lib/buffer.cc | 2 +- gnuradio-runtime/lib/math/fast_atan2f.cc | 2 +- gnuradio-runtime/lib/math/qa_fast_atan2f.cc | 2 +- gnuradio-runtime/lib/math/qa_math.cc | 2 +- gr-analog/lib/fmdet_cf_impl.cc | 2 +- gr-analog/lib/pll_carriertracking_cc_impl.cc | 2 +- gr-analog/lib/pll_freqdet_cf_impl.cc | 2 +- gr-analog/lib/pll_refout_cc_impl.cc | 2 +- gr-analog/lib/quadrature_demod_cf_impl.cc | 2 +- gr-analog/lib/rail_ff_impl.cc | 2 +- gr-atsc/lib/atsc_fpll.cc | 2 +- gr-atsc/lib/atsci_equalizer_lms2.cc | 2 +- gr-atsc/lib/atsci_sssr.cc | 2 +- gr-blocks/lib/complex_to_arg_impl.cc | 2 +- gr-blocks/lib/control_loop.cc | 2 +- gr-blocks/lib/udp_source_impl.cc | 2 +- gr-digital/lib/binary_slicer_fb_impl.cc | 2 +- gr-digital/lib/clock_recovery_mm_cc_impl.cc | 2 +- gr-digital/lib/clock_recovery_mm_ff_impl.cc | 2 +- gr-digital/lib/cma_equalizer_cc_impl.h | 2 +- gr-digital/lib/constellation.cc | 2 +- gr-digital/lib/constellation_receiver_cb_impl.cc | 2 +- gr-digital/lib/correlate_and_sync_cc_impl.cc | 2 +- gr-digital/lib/costas_loop_cc_impl.cc | 2 +- gr-digital/lib/kurtotic_equalizer_cc_impl.h | 2 +- gr-digital/lib/mpsk_receiver_cc_impl.cc | 2 +- gr-digital/lib/ofdm_frame_acquisition_impl.cc | 2 +- gr-digital/lib/ofdm_frame_sink_impl.cc | 2 +- gr-digital/lib/pfb_clock_sync_ccf_impl.cc | 2 +- gr-digital/lib/pfb_clock_sync_fff_impl.cc | 2 +- gr-noaa/lib/hrpt_pll_cf_impl.cc | 2 +- gr-qtgui/lib/HistogramDisplayPlot.cc | 2 +- 34 files changed, 36 insertions(+), 36 deletions(-) rename gnuradio-runtime/include/gnuradio/{math.h => math_utils.h} (98%) _______________________________________________ Discuss-gnuradio mailing list Discuss-gnuradio@gnu.org https://lists.gnu.org/mailman/listinfo/discuss-gnuradio