Hi Kevin,

no, they are not the same.
In the ofdm mod XML file (gr-digital/grc/digital_ofdm_mod.xml), the make element is:
grc_blks2.packet_mod_$(type.fcn)(digital.ofdm_mod(
                options=grc_blks2.options(
                        modulation="$modulation",
                        fft_length=$fft_length,
                        occupied_tones=$occupied_tones,
                        cp_length=$cp_length,
                        pad_for_usrp=$pad_for_usrp,
                        log=None,
                        verbose=None,
                ),
        ),
        payload_length=$payload_length,
)

So, OFDM mod is basically a packet encoder, which internally is a message queue based approach to managing packets. This is nice, because internally digital.ofdm_mod has a send_pkt method that encodes your message, enabling it to work asynchronously, it generates a sync-friendly, preambling, data-encoding framework, so it's a user-friendly data->symbols->preamble+symbols->ifft->cyclic prefixer->normalizer hier block, while ofdm_tx_core.png only shows the very basic princible of generating OFDM signals in GNU Radio.

Hope I was of a little assistance,
Marcus


Morning,

Sorry for taking so long to reply.

I have one question,
the block, "OFDM Mod" <-----> and these three, "OFDM Carrier Allocator, FFT, OFDM Cyclic Prefixer",
shown on the website, http://gnuradio.org/doc/doxygen/ofdm_tx_core.png

Are they doing the same thing?

Thanks






---------- Forwarded message ----------
From: *Martin Braun (CEL)* <martin.br...@kit.edu <mailto:martin.br...@kit.edu>>
Date: Fri, Sep 20, 2013 at 6:08 PM
Subject: Re: [Discuss-gnuradio] About setting the GRC block properties.
To: GNURadio Discussion List <discuss-gnuradio@gnu.org <mailto:discuss-gnuradio@gnu.org>>


On Fri, Sep 20, 2013 at 01:45:46PM -0500, Kevin wrote:
> "Virtual source" block shows "pre-ofdm", which means I need to create some
> blocks like "Virtual sink" labeled "pre-ofdm" before this?

Don't worry about these blocks, they are just to make the Figures look
complete (or rather, to label the inputs).

>     "I think you just need brackets around the carrier allocation table.
>     Also, use Python's range() to make stuff more readable."
>
>
> Can you explain it more specifically?
>
> bracket at which section?

You need more (). The carrier tables are vectors of vectors ((...), ...).
>
> "python's range()" I have no idea what this is?

Look up the range() function in Python.

MB

--
Karlsruhe Institute of Technology (KIT)
Communications Engineering Lab (CEL)

Dipl.-Ing. Martin Braun
Research Associate

Kaiserstraße 12
Building 05.01
76131 Karlsruhe

Phone: +49 721 608-43790 <tel:%2B49%20721%20608-43790>
Fax: +49 721 608-46071 <tel:%2B49%20721%20608-46071>
www.cel.kit.edu <http://www.cel.kit.edu>

KIT -- University of the State of Baden-Württemberg and
National Laboratory of the Helmholtz Association

_______________________________________________
Discuss-gnuradio mailing list
Discuss-gnuradio@gnu.org <mailto:Discuss-gnuradio@gnu.org>
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio




_______________________________________________
Discuss-gnuradio mailing list
Discuss-gnuradio@gnu.org
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

_______________________________________________
Discuss-gnuradio mailing list
Discuss-gnuradio@gnu.org
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

Reply via email to