I just added a gr_basic_add_const and gr_basic_multiply_const. Nick added the volk (and orc) implementations for the float32 and complex float32 implementations of the multiplier.
> > So I like everything about this but the name. We could stuff all of this > under the "gnuradio.gr" namespace in Python, or we could name this > "gr-math." > > Actually, while I was typing this, I'm thinking we rename the directory to > be "gr-blocks" but put them under the "gnuradio.gr" namespace. I'm Trying to avoid math so from gnuradio import math doesnt interfere with python's math import. Thats unfortunate, but I think this will be nicer with the python namespace changes you mentioned. #example import: from gnuradio import gr gr.filter.fir_interp(...) gr.math.add(...) gr.digital.costas_loop(...) Was that the goal? I think we can make this happen without too much trouble > expecting that since you've used different names for the blocks because of > the data-type handling that they won't collide with what's in guradio-core > right now. > So, my thoughts were: make new blocks that replicate the functionality in gr-core like filters, adders, etc. We dont delete the old blocks, so the API doesn't change. But if you want the performance improvement, you use the new blocks. Hopefully with these new blocks, we use volk where applicable, use new naming convention to make it easier to fit alternative data types, and avoid generation when possible. Eventually, gnuradio-core becomes nothing but the block framework and runtime. gr-filter takes the filter implementations and gr-<???> takes the very basic blocks like simple math operators, type conversions, and stream conversions. Hows that sound? -Josh _______________________________________________ Discuss-gnuradio mailing list Discuss-gnuradio@gnu.org https://lists.gnu.org/mailman/listinfo/discuss-gnuradio