Hi,

My package (Ray) relies on mpich2. The new name for mpich2 is mpich, but the 
name is still
mpich2 in el6.

So I defined a variable named mpichName.

I was wondering why nested macros like this
one are not working:

%{_%{mpichName}_load}
 
 
However, this works, but it is longer:
 
%if %mpichName == "mpich"
    %{_mpich_load}
%else
    %{_mpich2_load}
%endif


Is there a syntax to use "%{_%{mpichName}_load}" (or is there a better way to 
do it) ?                                    
-- 
devel mailing list
devel@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/devel
Fedora Code of Conduct: http://fedoraproject.org/code-of-conduct

Reply via email to