On 11/21/2013 05:34 PM, Rich Megginson wrote:
On 11/21/2013 08:36 AM, thierry bordaz wrote:
On 11/21/2013 04:22 PM, Rich Megginson wrote:
On 11/21/2013 01:58 AM, thierry bordaz wrote:
Hi,
The changes look very good.
I have a question regarding start/stop in Replica class. Why do not
you use the function self.agreement.schedule(agmdn,
interval='start') and self.agreement.schedule(agmdn, interval='stop') ?
I will change it to use schedule().
about the function 'agreement_dn(basedn, other)' why not putting it
into the Agreement class ?
Note that it uses the functions 'agreements' that is Replica but I
would expect it to be in Agreement class as well (renamed in 'list' ?).
Yes. I think I will change the names also, to pause() and resume().
I think the following methods should be moved to the Agreement
class: check_init start_and_wait wait_init start_async keep_in_sync
agreement_dn (rename to "dn") agreements (rename to "list") (also,
is it a problem that we have a method name "list" that is the same
as a python keyword/built-in?)
Hi Rich,
Yes that is good. When fixing
https://fedorahosted.org/389/ticket/47590 I noticed that with the new
Agreement class these functions also needed to be moved. I opened
https://fedorahosted.org/389/ticket/47600 for that. 'dn' and 'list'
are very good.
When eclipse was complaining with names (function or variable) same
as built-in keyword, I tried to change the name. Now I like 'list'
name and it was not a problem with self.replica.list(), so I would
vote to use 'list'.
New patch attached
Yes pause/resume always/never are good names.
ack.
regards
theirry
regards
thierry
Regards
thierry
On 11/21/2013 03:21 AM, Rich Megginson wrote:
--
389-devel mailing list
389-de...@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/389-devel
--
389-devel mailing list
389-de...@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/389-devel