I have thought that before. The rule I take is always to add the original data structure name as prefix, to avoid name space collision.
The meaning of " EDKII_DEVICE_IDENTIFIER_TYPE_PCI_GUID" is actually "EDKII_DEVICE_IDENTIFIER.TYPE_PCI_GUID" I have a little concern if I name it to "EDKII_DEVICE_TYPE_PCI", it may conflict with other generic name. As such, I prefer to keep the current definition. Thank you Yao Jiewen > -----Original Message----- > From: Ni, Ray <ray...@intel.com> > Sent: Thursday, November 7, 2019 12:32 PM > To: devel@edk2.groups.io; Ni, Ray <ray...@intel.com>; Yao, Jiewen > <jiewen....@intel.com> > Cc: Wang, Jian J <jian.j.w...@intel.com>; Wu, Hao A <hao.a...@intel.com>; > Lou, Yun <yun....@intel.com> > Subject: RE: [edk2-devel] [PATCH V2 2/4] MdeModulePkg/Include: Add > DeviceSecurity.h > > Jiewen, > "xxx_DEVICE_IDENTIFIER_TYPE_xxx" sounds a bit strange to me because > I feel "IDENTIFIER" and "TYPE" are different properties to describe a device. > Or you think some other GUIDs may be defined in future as the device ID? > > Thanks, > Ray > > > -----Original Message----- > > From: devel@edk2.groups.io <devel@edk2.groups.io> On Behalf Of Ni, Ray > > Sent: Thursday, November 7, 2019 9:59 AM > > To: Yao, Jiewen <jiewen....@intel.com>; devel@edk2.groups.io > > Cc: Wang, Jian J <jian.j.w...@intel.com>; Wu, Hao A <hao.a...@intel.com>; > > Lou, Yun <yun....@intel.com> > > Subject: Re: [edk2-devel] [PATCH V2 2/4] MdeModulePkg/Include: Add > > DeviceSecurity.h > > > > I see. PciIo or UsbIo instance is installed with a different GUID and > > consumer > > needs to parse the device path to understand what kind of instance (PciIo or > > UsbIo) should be used. > > > > > -----Original Message----- > > > From: Yao, Jiewen <jiewen....@intel.com> > > > Sent: Wednesday, November 6, 2019 4:25 PM > > > To: Ni, Ray <ray...@intel.com>; devel@edk2.groups.io > > > Cc: Wang, Jian J <jian.j.w...@intel.com>; Wu, Hao A > > > <hao.a...@intel.com>; Lou, Yun <yun....@intel.com> > > > Subject: RE: [edk2-devel] [PATCH V2 2/4] MdeModulePkg/Include: Add > > > DeviceSecurity.h > > > > > > HI > > > Good comment. Let me answer it in 2 parts. > > > > > > 1) The consumer may locate the deice path to know the device type. In > > > this part, you can treat this as redundant information. > > > > > > 2) But we still need a new GUID, because I will install the device > > > access protocol on this new GUID for the temporary access for the > > authentication driver only. > > > > > > I don't want to install the device access protocol to the original > > > UEFI spec defined GUID to notify everyone that the device is ready to > > > use, because I have seen some device drivers have callback function (such > > as ATA passthru, or NVME passthru) to start access the device once the > > device access protocol is installed. > > > > > > > > > Thank you > > > Yao Jiewen > > > > > > > -----Original Message----- > > > > From: Ni, Ray <ray...@intel.com> > > > > Sent: Wednesday, November 6, 2019 3:56 PM > > > > To: devel@edk2.groups.io; Yao, Jiewen <jiewen....@intel.com> > > > > Cc: Wang, Jian J <jian.j.w...@intel.com>; Wu, Hao A > > > > <hao.a...@intel.com>; Lou, Yun <yun....@intel.com> > > > > Subject: RE: [edk2-devel] [PATCH V2 2/4] MdeModulePkg/Include: Add > > > > DeviceSecurity.h > > > > > > > > > + /// > > > > > + /// Type of the device. > > > > > + /// This field is also served as a device Access protocol GUID. > > > > > + /// The device access protocol is installed on the DeviceHandle. > > > > > + /// The device access protocol is device specific. > > > > > + /// EDKII_DEVICE_IDENTIFIER_TYPE_PCI_GUID means the device > > access > > > > protocol is PciIo. > > > > > + /// EDKII_DEVICE_IDENTIFIER_TYPE_USB_GUID means the device > > access > > > > protocol is UsbIo. > > > > > + /// > > > > > + EFI_GUID DeviceType; > > > > > > > > Do we still need DeviceType? Consumer can query the Handle to > > > > understand the device type. > > > > -=-=-=-=-=-=-=-=-=-=-=- Groups.io Links: You receive all messages sent to this group. View/Reply Online (#50180): https://edk2.groups.io/g/devel/message/50180 Mute This Topic: https://groups.io/mt/40117495/21656 Group Owner: devel+ow...@edk2.groups.io Unsubscribe: https://edk2.groups.io/g/devel/unsub [arch...@mail-archive.com] -=-=-=-=-=-=-=-=-=-=-=-