Hi all, as per API review process, I’d like to propose a slight (but incompatible) change to these two APIs. From the Jira (https://issues.apache.org/jira/browse/TS-4731):
I'd like to propose that we modify these two APIs from: tsapi TSReturnCode TSHttpTxnIsInternal(TSHttpTxn txnp); tsapi TSReturnCode TSHttpSsnIsInternal(TSHttpSsn snap); to be tsapi int TSHttpTxnIsInternal(TSHttpTxn txnp); tsapi int TSHttpSsnIsInternal(TSHttpSsn snap); This is more inline with our current standards of using "int" as a boolean type. This is for example the prototype in TSVConnIsSsl() as well as in e.g. TSHttpTxnDebugSet(TSHttpTxn txnp, int on). — Leif