On 2/20/12 2:08 PM, Alan M. Carroll wrote:
Here is my Perl script for doing the renaming. It's simple enough that you can
determine the changes from it. To run it, put it the top directory and do
find . \( -name '*.cc' -o -name '*.h' -o -name '*.in' \) -exec perl
ts-995-rename.pl {} \; -print
The remaining open question is whether to keep the pton, ntop, and nptop stems
or change them to _string_to_addr, _addr_to_string, _addr_port_to_string for
readability.
Presumably we will also rename ink_inet.h to ts_ip.h after this change.
#!/usr/bin/perl -w -i -p
use strict;
Looks good, except, didn't we decide that the "ts" (and TS) prefix was
preserved for public APIs etc., while internally in the code, we use ats ? I
did that for e.g. ink_malloc, which became ats_malloc.
-- Leif