Thanks for the reviews. Daniel Shahaf wrote: > Missing @since. [...]
r1898461. >> +#include "../libsvn_wc/wc.h" > > I don't think libsvn_client is allowed to use this header. I'll fix that later. >> +* compatible with Subversion v1.8 to v1.15 (WC format 31) >> +* compatible with Subversion v1.15 (WC format 32) > > Bikeshed, but the bullet point parses as a sentence fragment. Suggest > instead: > > * format 31, compatible with Subversion v1.8 to v1.15 I had wanted to present the (minimum) compatible-version as the primary info and the WC format number as secondary. However, it does indeed work better that way. Also the "to 1.15" is implicit in being supported by 1.15 (unless we were to have disjoint support ranges, but the reader isn't likely to assume that). Continuing that way, I can then simplify that "get supported versions list" API, first removing the "max supported version" from that struct, and then by using another function to convert from wc-format number to min-supported version, we can get rid of that struct entirely. Much cleaner. Return just a list of wc-format ints. I'll do that soon. Output will be, I suggest, like this: * WC format 31, compatible with Subversion v1.8 and newer * WC format 32, compatible with Subversion v1.15 and newer - Julian