On 10 March 2015 at 13:10, <stef...@apache.org> wrote: > Author: stefan2 > Date: Tue Mar 10 10:10:30 2015 > New Revision: 1665437 > > URL: http://svn.apache.org/r1665437 > Log: > Correct and complete docstrings in the FS API after 1.9 review. > No functional change. > > * subversion/include/svn_fs.h > (svn_fs_backend_names): New Doxygen group allowing us to refer to the > pre-defined set of backends. Move to front due > to issues with group nesting. > (SVN_FS_CONFIG_COMPATIBLE_VERSION): Works for the current release as well. > (svn_fs_open2): Correct cleanup behavior description for RESULT_POOL. > Document SCRATCH_POOL. > (svn_fs_upgrade_notify_t): Grammar fix. > (svn_fs_upgrade2): Refer to latest repos API. > (svn_fs_hotcopy3): BDB is the only backend not sending notifications. > Document CANCEL_FUNC. > (svn_fs_compare_ids, > svn_fs_check_related): "Now" is 1.9. > (svn_fs_props_changed): Fix confusing wording. > (svn_fs_info_format, > svn_fs_lock_target_t): For clarity, remove '()' from function names in > @see line. > (svn_fs_fsfs_info_t): Make comment visible to doxygen. > (svn_fs_info_placeholder_t): For clarity, remove '()' from function names > in @see line. > (svn_fs_info): Mention FSX alongside FSFS. > (svn_fs_info_dup): Update pool usage documentation. > > Modified: > subversion/trunk/subversion/include/svn_fs.h > > Modified: subversion/trunk/subversion/include/svn_fs.h > URL: > http://svn.apache.org/viewvc/subversion/trunk/subversion/include/svn_fs.h?rev=1665437&r1=1665436&r2=1665437&view=diff [...]
> - * @note Using FS ID based functions is now discouraged and may be fully > - * deprecated in future releases. New code should use > #svn_fs_node_relation() > - * and #svn_fs_node_relation_t instead. > + * @note Using FS ID based functions is discouraged since 1.9 and may be > + * fully deprecated in future releases. New code should use > + * #svn_fs_node_relation() and #svn_fs_node_relation_t instead. > */ > int > svn_fs_compare_ids(const svn_fs_id_t *a, > @@ -917,9 +933,9 @@ svn_fs_compare_ids(const svn_fs_id_t *a, > /** Return TRUE if node revisions @a id1 and @a id2 are related (part of the > * same node), else return FALSE. > * > - * @note Using FS ID based functions is now discouraged and may be fully > - * deprecated in future releases. New code should use > #svn_fs_node_relation() > - * and #svn_fs_node_relation_t instead. > + * @note Using FS ID based functions is discouraged since 1.9 and may be > + * fully deprecated in future releases. New code should use > + * #svn_fs_node_relation() and #svn_fs_node_relation_t instead. > */ Stefan, You have proposed to deprecate the FS ID functions [1], but got well justified objections [2]. Are you going to remove these "future deprecation" clauses from svn_fs.h or you have alternative ideas regarding this matter? [1] http://svn.haxx.se/dev/archive-2013-12/0127.shtml [2] http://svn.haxx.se/dev/archive-2013-12/0132.shtml -- Ivan Zhakov