Gabriela Gibson <gabriela.gib...@gmail.com> writes:

>>>     if (config)
>>>       {
>>> -      svn_config_t *cfg = svn_hash_gets(config, 
>>> SVN_CONFIG_CATEGORY_CONFIG);
>>> +      svn_config_t *cfg;
>>> +
>>> +      cfg = svn_hash_gets(config, SVN_CONFIG_CATEGORY_CONFIG);
>>
>> Why?  This doesn't seem to serve any useful purpose (in fact, I think it 
>> makes
>> the code harder to read).
>>
>
> Because (if I understood this correctly!) the compiler builds more efficient 
> code and the startup time of the application is improved.
>
> "To summarize, it is always preferable to add variables
> as uninitialized or initialized with zero as opposed to as
> initialized with a value other than zero."
>
> See Page 16 here:
> http://software.intel.com/sites/default/files/m/a/1/e/dsohowto.pdf

The quote is referring to static variables, it doesn't apply to stack
variables.

-- 
Certified & Supported Apache Subversion Downloads:
http://www.wandisco.com/subversion/download

Reply via email to