Hyrum,

I was thinking of adding, what I have implemented so far, on top of the
existing branch as there is minimal overlap and I would like to incorporate
the existing work.  Therefore, my plan is to do the following,
not necessarily in the below order:

1. Rename SVNReposNaming to SVNRa.

    I have used the variations of SVNRa for the C++ and java classes
related to the  svn_ra_session_t as it conveys the meaning (IMHO) yet
remains short.  I realize that A should have been capital too, but SVNRA
looks too much like a java constant and SvnRA is not consistent with
SVNClient.

2. Create objects in C++ returning jobjects to the calling code.

   In my approach object creation is done in the C++ code rather than
having it split between Java and C++. It felt to me as cleaner to have it
in one place rather than split between java and C++. You can see the code
for that in SVNRaFactory.java in patch 18 and
org_apache_subversion_javahl_ra_SVNRaFactory.cpp in patch 20

3. Use longs in native function calls where apr_time_t is used to
avoid 2359<http://subversion.tigris.org/issues/show_bug.cgi?id=2359>
and
a wrapper function that uses Data and change GetDateRevision method
accordingly.

4. Use runtime rather than checked exceptions.

    I strongly dislike checked exceptions in code paths where there is
no expected recovery logic that can be applied. This just forces people to
either write a lot of try catch blocks that don't have any useful logic,
propagate the exceptions through all the methods, or catch and wrap the
exception in a RuntimeException derived class.

5. Apply patches, updated to be compatible with existing code on the branch
(except the class naming)

If I should adjust my approach please let me know.

Thank you,

Vladimir

On Sat, May 19, 2012 at 1:23 AM, Hyrum K Wright
<hyrum.wri...@wandisco.com>wrote:

> Vladimir,
> Feel free to delete the existing branch and start a new one for your
> work.  Your patches look to be much more complete than what exists on
> the branch now.
>
> -Hyrum
>
> On Fri, May 18, 2012 at 4:12 PM,  <v...@apache.org> wrote:
> > Author: vmpn
> > Date: Fri May 18 21:12:26 2012
> > New Revision: 1340253
> >
> > URL: http://svn.apache.org/viewvc?rev=1340253&view=rev
> > Log:
> > * COMMITTERS: Added myself as partial committer for the javahl-ra branch
> >
> > Modified:
> >    subversion/trunk/COMMITTERS
> >
> > Modified: subversion/trunk/COMMITTERS
> > URL:
> http://svn.apache.org/viewvc/subversion/trunk/COMMITTERS?rev=1340253&r1=1340252&r2=1340253&view=diff
> >
> ==============================================================================
> > --- subversion/trunk/COMMITTERS [UTF-8] (original)
> > +++ subversion/trunk/COMMITTERS [UTF-8] Fri May 18 21:12:26 2012
> > @@ -201,6 +201,7 @@ giorgio_valoti   Giorgio Valoti <giorgio
> >                                                               br.)
> >         holden   Holden Karau <hol...@pigscanfly.ca>
> (scheme-bindings br.)
> >          moklo   Morten Kloster <mor...@gmail.com>
> (diff-improvements br.)
> > +          vmpn   Vladimir Berezniker <v...@hitechman.com>
>  (javahl-ra br.)
> >
> >   Subprojects that are complete, abandoned or have moved elsewhere:
> >
> >
> >
>
>
>
> --
>
> uberSVN: Apache Subversion Made Easy
> http://www.uberSVN.com/
>

Reply via email to