On Thu, 2010-12-02 at 17:40 +0200, Daniel Shahaf wrote: > Julian Foad wrote on Thu, Dec 02, 2010 at 15:34:48 +0000: > > First step: this patch fixes the comments. Good to commit? > > > > [[[ > > Index: subversion/libsvn_fs_fs/fs_fs.c > > =================================================================== > > --- subversion/libsvn_fs_fs/fs_fs.c (revision 1041350) > > +++ subversion/libsvn_fs_fs/fs_fs.c (working copy) > > @@ -7606,8 +7606,8 @@ pack_shard(const char *revs_dir, > > SVN_ERR(svn_io_set_file_read_only(manifest_file_path, FALSE, pool)); > > > > /* Update the min-unpacked-rev file to reflect our newly packed shard. > > - * (ffd->min_unpacked_rev will be updated by open_pack_or_rev_file().) > > - */ > > + * (This doesn't update ffd->min_unpacked_rev. That will be updated by > > + * open_pack_or_rev_file() when necessary.) */ > > Didn't you mean s/open_pack_or_rev_file/update_min_unpacked_rev/?
I was just modifying the existing comment and assuming it had some truth or meaning in mentioning open_pack_or_rev_file(). Not sure what, exactly. > > final_path = svn_dirent_join(fs_path, PATH_MIN_UNPACKED_REV, iterpool); > > SVN_ERR(svn_stream_open_unique(&tmp_stream, &tmp_path, fs_path, > > svn_io_file_del_none, iterpool, > > iterpool)); > > @@ -7674,9 +7674,8 @@ pack_revprop_shard(svn_fs_t *fs, > > SVN_ERR(svn_sqlite__insert(NULL, stmt)); > > } > > > > - /* Update the min-unpacked-rev file to reflect our newly packed shard. > > - * (ffd->min_unpacked_rev will be updated by open_pack_or_rev_file().) > > - */ > > + /* Update the min-unpacked-revprop file to reflect our newly packed > > shard. > > + * (This doesn't update ffd->min_unpacked_revprop.) */ > > final_path = svn_dirent_join(fs_path, PATH_MIN_UNPACKED_REVPROP, > > iterpool); > > SVN_ERR(svn_stream_open_unique(&tmp_stream, &tmp_path, fs_path, > > svn_io_file_del_none, iterpool, > > iterpool)); > > ]]] > > > > +1 r1041422. If you the point above still needs changing, please do so or let me know. - Julian