Hi tison,

Thanks for your suggestions! We have several questions on [build]:

> build - all things related to the build system, including tools,
deployment logic, maven changes, packaging logics, docker image, build
scripts.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

# 1.  "tools"

What do you refer to? Plugins?

Besides, the existing scope, [tool], refers to Pulsar CLI tools [1].
We're considering to rename it to [cli] since:
a. "cli" is more clear and short
b. Save the word "tool" for future use

Does it make sense?

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

# 2. "deployment logic"

Seems that it's an obsolete module and has not been updated for a long
while.
If so, can we ignore this?

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

# 3. Does "packaging logics" belong to [admin]? [2]

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

# 4. How about defining [build] refer to the following?

- Dependency (Maven)

In this way, we do not have the scope [dependency] since the changes to
dependency belong to [build].

- Docker

- Build or release script

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Thank you for your reply!

[1]
https://docs.google.com/document/d/1d8Pw6ZbWk-_pCKdOmdvx9rnhPiyuxwq60_TrD68d7BA/edit?pli=1#bookmark=id.khz275ok35u5
[2]
https://docs.google.com/document/d/1d8Pw6ZbWk-_pCKdOmdvx9rnhPiyuxwq60_TrD68d7BA/edit?pli=1#bookmark=id.nnekhkthmwlh

Yu and Zixuan

On Mon, Aug 22, 2022 at 12:40 PM Yu <li...@apache.org> wrote:

> Thank you tison and Zixuan!
>
> Agree on the following aspects:
>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>
> # 1. Remove 3 [scope]s
>
> - Remove [workflow] since it can be replaced with other scopes
> eg.
> "[feat][workflow] Add instructions for previewing website changes"
> can be written as
> "[feat][doc] Add instructions for previewing website changes"
>
> - Remove [depoly] since changes to deployment can be represented by other
> [scope]s.
>
> - Remove [pkg]since it refers to package API [1], which belongs to [admin].
>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>
> # 2. Update 4 [scope]s
>
> - Add [meta], which refers to changes to metadata.
>
> - Add [storage], which refers to changes to managed ledger.
>
> - Rename [ts] to [offloaded], which refers to changes to tiered storage.
>
> - Rename [func] to [fn], which refers to changes to function.
>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>
> # 3. Remain the same
>
> These formats are fine to go:
>
> - Submit breaking changes
> [feat][broker]! Support xx
>
> - Submit PIP changes
> [feat][broker] PIP-198: Support xx
>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>
> Feel free to comment, thank you!
>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>
> [1] https://pulsar.apache.org/docs/next/admin-api-packages
>
> Yu and Zixuan
>
> On Fri, Aug 19, 2022 at 6:21 PM Zixuan Liu <node...@gmail.com> wrote:
>
>> +1 for fcn -> fn
>> +1 for ts -> offloader
>>
>> +1 * ci - CI workflow changes or debugging.
>> +1 * build - all things related to the build system, including tools,
>> deployment logic, maven changes, packaging logics, docker image,
>> buildscripts.
>>
>> `pkg` should belong to the `admin` scope, so suggest using the `admin`
>> instead `pkg`.
>>
>> `tool` is pulsar-admin, pulsar, pulsar-client, and so on cli, so keep
>> using
>> the `tool`.
>>
>> deploy should belong to the `build` scope`, so suggest using the `build`
>> instead `deploy`.
>>
>>
>> tison <wander4...@gmail.com> 于2022年8月19日周五 17:46写道:
>>
>> > BTW, how can I sort changes for the metadata store?
>> >
>> > Best,
>> > tison.
>> >
>> >
>> > tison <wander4...@gmail.com> 于2022年8月19日周五 17:44写道:
>> >
>> > > To proposal a workable solution, I suggest:
>> > >
>> > > replace
>> > >
>> > > * pkg
>> > > * tool
>> > > * deploy
>> > > * ci
>> > > * workflow
>> > > * build
>> > >
>> > > with
>> > >
>> > > * ci - CI workflow changes or debugging.
>> > > * build - all things related to the build system, including tools,
>> > > deployment logic, maven changes, packaging logics, docker image, build
>> > > scripts.
>> > >
>> > > Best,
>> > > tison.
>> > >
>> > >
>> > > tison <wander4...@gmail.com> 于2022年8月19日周五 17:41写道:
>> > >
>> > >> > I intended to mean changes to "process / standard / guide" [2]
>> rather
>> > >> than "CI workflow", but it still causes confusion.
>> > >>
>> > >> How can a PR be relevant to these things? I think the result should
>> be
>> > >> either CI workflow changes or document updates. We don't need a
>> > dedicated
>> > >> "workflow" in such situations.
>> > >>
>> > >> > build system or external dependencies.
>> > >>
>> > >> So, it overlaps with deps. While I can regard it as
>> Maven/Docker/Build
>> > >> script related changes, we may not have "pkg", "tool", "deploy" that
>> can
>> > >> overlap with this.
>> > >>
>> > >> Best,
>> > >> tison.
>> > >>
>> > >>
>> > >> tison <wander4...@gmail.com> 于2022年8月19日周五 17:38写道:
>> > >>
>> > >>> As for the type candidates:
>> > >>>
>> > >>> LGTM. No comment here.
>> > >>>
>> > >>> As for the scope candidates:
>> > >>>
>> > >>> +1 for dep -> deps
>> > >>> +1 for fcn -> fn
>> > >>>   Among most communities and language conventions, the abbr of
>> function
>> > >>> is fn (Rust), fun (Erlang), or func (Golang). No fcn IIRC. I'd
>> prefer
>> > the
>> > >>> short one, fn.
>> > >>> +1 for ts -> offloader
>> > >>>   If I get it right, tiered storage is offloader. We can save one
>> word
>> > >>> while keeping semantic.
>> > >>>
>> > >>> I don't know clearly what is:
>> > >>> * pkg
>> > >>> * tool
>> > >>> * deploy
>> > >>> * ci
>> > >>> * workflow
>> > >>> * build
>> > >>> They look quite similar or overlapping.
>> > >>>
>> > >>> Rest LGTM.
>> > >>>
>> > >>> As for the remaining issues:
>> > >>>
>> > >>> - Submit breaking changes
>> > >>> [feat][broker]! Support xx
>> > >>>
>> > >>> This is fine. Since we don't verify what follows the [type][scope]
>> > >>> section, it doesn't block the proposal.
>> > >>>
>> > >>> - Submit PIP changes
>> > >>> [feat][broker] PIP-198: Support xx
>> > >>>
>> > >>> The same as before. Contributors can name whatever they like. We
>> don't
>> > >>> set too complex rules.
>> > >>>
>> > >>> - Cherry pick changes [4]
>> > >>> Choice A: [fix][broker][branch-2.9] xxx
>> > >>> Choice B: [fix][broker] xxx. And add "cherry pick xxx to
>> branch-2.9" in
>> > >>> the
>> > >>> PR description.
>> > >>>
>> > >>> I'd prefer [fix][broker][BP-2.9] to save some letters. This is how
>> the
>> > >>> Flink community does. BP means backport. But yes, it's not a
>> > requirement
>> > >>> but a suggestion.
>> > >>>
>> > >>>
>> > >>> Best,
>> > >>> tison.
>> > >>>
>> > >>
>> >
>>
>

Reply via email to