Hi Aparajita, Thanks for the proposal. Indeed the schema registry was meant to be pluggable since the beginning although we skipped the actual "plugging" part. It would be good to actually see multiple implementations there.
I don't see any risk in this proposal and it's a good time to make breaking changes to the SchemaRegistry interface since there are not (yet) any implementation other than the default one. > Renaming a few methods in the SchemaRegistryService interface to reflect > their behavior. The changes are: > Rename deleteSchema to putEmptySchema in SchemaRegistryService My only concern, based on current behavior, is that in some places in the code we're calling `deleteSchema()` while actually we should be calling `deleteSchemaStorage()` (using the current names). I guess that's probably due to the misleading nature of the method names. We should double-check these usages to make sure the expected operation is applied. Matteo -- Matteo Merli <mme...@apache.org> On Mon, Feb 21, 2022 at 7:53 AM Aparajita Singh <aparajita.1...@gmail.com> wrote: > > Hi, > Please review this proposal: https://github.com/apache/pulsar/issues/14395 > > -- > Thanks, > Aparajita