On 28 September 2016 at 14:22, Daniele Di Proietto <diproiet...@ovn.org> wrote: > Is there any reason not to squash this with the previous patch?
It was an attempt at separating functional changes from cosmetic. > If you want to keep two commits for clarity I would split it like: > > commit1) move the block above odp_flow_key_to_flow() > commit2) factor out xlate_ukey() in the second. You're right, and this highlighted a bug where the ukey->xcache would be allocated (empty) in odp translation / xlate lookup error cases. I'm going with your suggestion to keep them separate. _______________________________________________ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/listinfo/dev