This RFC patch addresses the restrictions placed on dpdk port names. Currently dpdk ports must be named dpdkX where X is the dpdk port-id. This patch removes this restriction and introduces the requirement to specify the pci address of the device in the other_config db. eg.
ovs-vsctl add-port br0 my-port -- set Interface my-port type=dpdk options:dpdk-pci=0000:06:00.0 This patch is a work in progress and minimal testing has been performed, although a basic setup switching between two dpdk ports has been verified to work. This version of the patch has been implemented on top of the hotplug support patch (v7): http://openvswitch.org/pipermail/dev/2016-July/075350.html I'd welcome feedback on both the idea and the approach. v3: - remove global pci list - remove unnecessary parenthesis - remove return from void fn - print pci like dpdk - fix port ranges v2: - Applied changes on top of hotplug patch and made the combination compatible. INSTALL.DPDK-ADVANCED.md | 2 +- INSTALL.DPDK.md | 10 ++-- NEWS | 2 + lib/netdev-dpdk.c | 132 ++++++++++++++++++++++++++++++++++++++--------- 4 files changed, 116 insertions(+), 30 deletions(-) -- 2.4.3 _______________________________________________ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/listinfo/dev