This is the third and last part of XPS patch-set which contains implementation of manual pinning of rx queues to pmd threads.
Manual pinning API was discussed here: http://openvswitch.org/pipermail/dev/2016-July/074674.html This patch-set based on top of "[PATCH v4] XPS implementation (Second part of XPS patch-set)." http://openvswitch.org/pipermail/dev/2016-July/075122.html First patch implements passing of 'other_config' column from 'Interface' table to datapath. This is required to pass pinning configuration to dpif-netdev. Note: IMHO, pinning configuration is not connected with netdev, so, it shouldn't be passed via 'options'. 'other_config' is not used by anyone, so, I think, it's a good place to store such information and push it down to datapath. Second patch is a refactoring to decrease code duplication. Third patch is a modified version of the last patch from v2: "dpif-netdev: Add dpif-netdev/pmd-rxq-set appctl command." It was modified to get configuration pushed via 'port_set_config'. Ilya Maximets (3): bridge: Pass interface's configuration to datapath. util: Expose function nullable_string_is_equal. dpif-netdev: Introduce pmd-rxq-affinity. INSTALL.DPDK.md | 49 ++++++++- NEWS | 2 + lib/dpif-netdev.c | 231 ++++++++++++++++++++++++++++++++++--------- lib/dpif-netlink.c | 1 + lib/dpif-provider.h | 5 + lib/dpif.c | 17 ++++ lib/dpif.h | 1 + lib/util.c | 6 ++ lib/util.h | 1 + ofproto/ofproto-dpif-ipfix.c | 6 -- ofproto/ofproto-dpif-sflow.c | 6 -- ofproto/ofproto-dpif.c | 16 +++ ofproto/ofproto-provider.h | 5 + ofproto/ofproto.c | 29 ++++++ ofproto/ofproto.h | 2 + tests/pmd.at | 6 ++ vswitchd/bridge.c | 2 + vswitchd/vswitch.xml | 23 +++++ 18 files changed, 344 insertions(+), 64 deletions(-) -- 2.7.4 _______________________________________________ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/listinfo/dev