let me explain what netdev-bsd does first.
on some platform "tap" interfaces are always named automatically by kernel
itself
and there's no way to rename them.  say, they always will have names like
"tap0".
so if you does "ovs-vsctl add-port br0 foo",
  ovs_name = "foo"
  kernel_name = "tap0"

now, you are going to add another name for openflow. let's call it of_name.
eg. "ovs-vsctl add-port br0 foo -- set int foo ofname=wan",
  of_name = "wan"
  ovs_name = "foo"
  kernel_name = "tap0"

while i don't have strong opinions either ways,
i'm not sure why you want to use different names for of_name and ovs_name
in the first place.  eg. what's wrong with "ovs-vsctl add-port br0 wan".
can you explain a little?

On Mon, Apr 18, 2016 at 10:37 AM, Xiao Liang <shaw.l...@gmail.com> wrote:

> Hi Ben, Yamamoto-san,
>
> Kindly remind you of this thread. Would like to hear your preference
> on the way to implement this feature.
>
> On Mon, Apr 11, 2016 at 11:18 PM, Ben Pfaff <b...@ovn.org> wrote:
> > On Mon, Apr 11, 2016 at 04:30:04PM +0800, Xiao Liang wrote:
> >> On Mon, Apr 11, 2016 at 3:42 PM, Takashi Yamamoto <
> yamam...@midokura.com> wrote:
> >> > hi,
> >> >
> >> > have you considered the opposite way?
> >> > ie. have an ability to specify the device name.
> >> >
> >> > netdev-bsd already has a distinction between "kernel name" and "ovs
> name".
> >> >
> >>
> >> Hi,
> >>
> >> I'm not familiar with netdev-bsd code, but I think this approach will
> >> make ports more difficult to manage and need much more effort.
> >
> > Yamamoto-san: thanks for bringing this up.  I'm going to wait for you
> > and Xiao to talk this through a bit before continuing review.
> _______________________________________________
> dev mailing list
> dev@openvswitch.org
> http://openvswitch.org/mailman/listinfo/dev
>
_______________________________________________
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev

Reply via email to