From: Jean Sacren <saki...@gmail.com>

commit 6b001e682e90 ("openvswitch: Use Geneve device.")

The commit above introduced 'port_no' as the name for the member of
struct geneve_port. The correct name should be 'dst_port' as described
in the kernel doc. Let's fix that member name and all the pertinent
instances so that both doc and code would be consistent.

Signed-off-by: Jean Sacren <saki...@gmail.com>
---
 net/openvswitch/vport-geneve.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/net/openvswitch/vport-geneve.c b/net/openvswitch/vport-geneve.c
index e41cd12d9b2d..30ab8e127288 100644
--- a/net/openvswitch/vport-geneve.c
+++ b/net/openvswitch/vport-geneve.c
@@ -34,7 +34,7 @@ static struct vport_ops ovs_geneve_vport_ops;
  * @dst_port: destination port.
  */
 struct geneve_port {
-       u16 port_no;
+       u16 dst_port;
 };
 
 static inline struct geneve_port *geneve_vport(const struct vport *vport)
@@ -47,7 +47,7 @@ static int geneve_get_options(const struct vport *vport,
 {
        struct geneve_port *geneve_port = geneve_vport(vport);
 
-       if (nla_put_u16(skb, OVS_TUNNEL_ATTR_DST_PORT, geneve_port->port_no))
+       if (nla_put_u16(skb, OVS_TUNNEL_ATTR_DST_PORT, geneve_port->dst_port))
                return -EMSGSIZE;
        return 0;
 }
@@ -83,7 +83,7 @@ static struct vport *geneve_tnl_create(const struct 
vport_parms *parms)
                return vport;
 
        geneve_port = geneve_vport(vport);
-       geneve_port->port_no = dst_port;
+       geneve_port->dst_port = dst_port;
 
        rtnl_lock();
        dev = geneve_dev_create_fb(net, parms->name, NET_NAME_USER, dst_port);
_______________________________________________
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev

Reply via email to