v1->v2: - Drop first patch that was merged. - Update 1/3 to fix unsafe HMAP_FOR_EACH_WITH_HASH usage. - Fix issues in pre-existing code to address the same unsafe HMAP_FOR_EACH_WITH_HASH usage. v2->v3: - rebase on top of patch that renamed 'ovn' to 'ovn-sb' v3->v4: - rebase. - Add patch 4 to rename ovn-nbd to ovn-northbound.
[PATCH 1/4] ovn-nbd: Match bindings on lport name. [PATCH 2/4] ovn-nbd: Don't shadow hash_node variable. [PATCH 3/4] ovn-nbd: Fix unsafe HMAP_FOR_EACH_WITH_HASH usage. [PATCH 4/4] ovn: Rename ovn-nbd to ovn-northbound. b/Makefile.am | 1 b/ovn/.gitignore | 1 b/ovn/TODO | 6 b/ovn/automake.mk | 5 b/ovn/northbound/.gitignore | 1 b/ovn/northbound/automake.mk | 4 b/ovn/northbound/ovn-northbound.c | 518 ++++++++++++++++++++++++++++++++++++++ b/ovn/ovn-architecture.7.xml | 62 ++-- b/ovn/ovn-nb.xml | 10 b/ovn/ovn-sb.xml | 8 b/tutorial/ovs-sandbox | 12 ovn/ovn-nbd.c | 496 ------------------------------------ 12 files changed, 574 insertions(+), 550 deletions(-) -- Russell Bryant _______________________________________________ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/listinfo/dev