On Sep 18, 2014, at 4:35 AM, Samuel Ghinet <sghi...@cloudbasesolutions.com>
 wrote:

> Hi Nithin,
> 
> Good catch!
> 
> I would normally prefer the validation in a function to be done like:
> ret = TRUE;
> 
> if (fail_cond_1) {
>  log();
>  ret = FALSE;
>  goto done;
> }
> 
> if (fail_cond_2) {
>  log();
>  ret = FALSE;
>  goto done;
> }
> 
> done:
> return ret;
> 
> It would be a bit more text, but I think it improves clarity a bit on the 
> ways "ret" is used and changed.
> 
> Anyway, it's good the way it is in NlAttrValidate as well.
> 
> Acked-by: Samuel Ghinet <sghi...@cloudbasesolutions.com>

Thanks for the review. I've incorporated your comments.

-- Nithin
_______________________________________________
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev

Reply via email to