Used some 'free time' on day 2 of 2014 hackerathon to come up with this
series that improves how hash APIs are used throughout OVS. These changes
are mainly aimed at improving code readability. They should not degrade
the hash quality and may improve performance in some cases. But I did
not attempt any performance measurements.

Andy Zhou (3):
  lib/hash.h: fix hash_2words
  lib/hash.h: add hash_uint64()
  lib/packet.h: add hash_mac()

 lib/cfm.c                    |    2 +-
 lib/classifier.c             |    2 +-
 lib/hash.h                   |   14 +++++++++++++-
 lib/mac-learning.c           |    4 +---
 lib/packets.c                |    6 ++----
 lib/packets.h                |   11 +++++++++++
 ofproto/bond.c               |    2 +-
 ofproto/ofproto-dpif-xlate.c |    2 +-
 ofproto/ofproto.c            |    3 +--
 9 files changed, 32 insertions(+), 14 deletions(-)

-- 
1.7.9.5

_______________________________________________
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev

Reply via email to