On Tue, Oct 29, 2013 at 4:26 PM, Jesse Gross <je...@nicira.com> wrote:
> On Tue, Oct 29, 2013 at 2:10 PM, Pravin B Shelar <pshe...@nicira.com> wrote:
>> diff --git a/datapath/linux/compat/include/linux/netdevice.h 
>> b/datapath/linux/compat/include/linux/netdevice.h
>> index c5c366b..14624bb 100644
>> --- a/datapath/linux/compat/include/linux/netdevice.h
>> +++ b/datapath/linux/compat/include/linux/netdevice.h
>>  #ifdef HAVE_RHEL_OVS_HOOK
>> -extern struct sk_buff *(*openvswitch_handle_frame_hook)(struct sk_buff 
>> *skb);
>> -extern int nr_bridges;
>> +typedef struct sk_buff *(openvswitch_handle_frame_hook_t)(struct sk_buff 
>> *skb);
>> +extern openvswitch_handle_frame_hook_t *openvswitch_handle_frame_hook;
>>  #endif
>
> [...]
>
>>  #if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,36) || \
>>      defined HAVE_RHEL_OVS_HOOK
>> -static inline int netdev_rx_handler_register(struct net_device *dev,
>> -                                            void *rx_handler,
>> -                                            void *rx_handler_data)
>> -{
>> +
>>  #ifdef HAVE_RHEL_OVS_HOOK
>
> Should we combine these two blocks to make it easier to read?
>
I combined it and pushed to master.

Thanks.

> Acked-by: Jesse Gross <je...@nicira.com>
_______________________________________________
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev

Reply via email to