Out of curiosity, did you consider the name xassert() as an alternative to ovs_assert()? It has the advantage of following our established convention.
+ static int reentry; > I'm not sure if the C spec strictly requires it, but I would feel more comfortable if we initialized this to 0 explicitly. > + switch (reentry++) { > + case 0: > + VLOG_ABORT("%s: assertion %s failed in %s()", > + where, condition, function); > + /* not reached */ > Minor style bit I may go ahead and make this an abort() for clarity. I.E. ovs_abort(); /* not reached */ Acked-by: Ethan Jackson <et...@nicira.com>
_______________________________________________ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/listinfo/dev