This is a rollup of all the outstanding, uncommitted patches I have posted that relate to OF1.1 and OF1.2 support, plus a few more in various states of completeness.
It begins with the ofp11_match v2 series most recently posted on June 9. I believe that these are unchanged from the previous posting: openflow-1.1.h: Fix OFPFW11_* definitions. openflow-1.0: Rename ofp_match to ofp10_match, OFPFW_* to OFPFW10_*. packets: Define IPPROTO_SCTP if not provided by <netinet/in.h>. packets: Add ETH_TYPE_MPLS and ETH_TYPE_MPLS_MCAST. ofp-util: Implement translation to and from OpenFlow 1.1 ofp_match. Allow general masking of IPv4 addresses rather than just CIDR masks. Allow general masking of IPv6 addresses rather than just CIDR masks. Followed by the unnamed series also posted on June 9: ofp-util: Remove unused functions make_add_simple_flow(), make_del_flow(). openflow-1.0.h: Clarify meaning of nw_tos in struct ofp_action_nw_tos. ofp-util: Improve return type of ofputil_decode_packet_in(). ofp-util: Add OFPUTIL_ACTION_INVALID to enum ofputil_action_code. Introduce ofpacts, an abstraction of OpenFlow actions. The following additional patches are in decent shape: ofp-util: Remove unused functions. openflow: Separate flow stats headers from their bodies. openflow: Rename OpenFlow 1.0 statistics messages with "10" infix. The following additional patches are really just works in progress. The first two kind of work as-is, the last three don't even build: ofp-actions: Support decoding OpenFlow 1.1 instructions and actions. ofp-util: Refaotor ofputil_decode_msg_type__() for extensibility. ofp-util: work on OF1.1 stats messages openflow: Separate OF1.0, OF1.1 flow_mod constants and types. ofp-util: Work on decoding OF1.1 flow_mods. DESIGN | 33 + NEWS | 8 +- build-aux/extract-ofp-errors | 1 + include/openflow/nicira-ext.h | 52 +- include/openflow/openflow-1.0.h | 202 +--- include/openflow/openflow-1.1.h | 89 +- include/openflow/openflow-1.2.h | 6 +- include/openflow/openflow-common.h | 128 ++- lib/automake.mk | 2 + lib/autopath.c | 70 +- lib/autopath.h | 15 +- lib/bundle.c | 277 +++--- lib/bundle.h | 26 +- lib/compiler.h | 20 +- lib/flow.h | 5 +- lib/learn.c | 672 ++++++------- lib/learn.h | 17 +- lib/learning-switch.c | 124 ++-- lib/learning-switch.h | 2 +- lib/meta-flow.c | 33 +- lib/meta-flow.h | 1 - lib/multipath.c | 160 ++-- lib/multipath.h | 18 +- lib/nx-match.c | 200 ++-- lib/nx-match.h | 31 +- lib/ofp-actions.c | 1581 +++++++++++++++++++++++++++ lib/ofp-actions.h | 482 +++++++++ lib/ofp-errors.h | 8 +- lib/ofp-parse.c | 265 +++--- lib/ofp-parse.h | 2 +- lib/ofp-print.c | 479 +++------- lib/ofp-print.h | 9 +- lib/ofp-util.c | 2050 +++++++++++++++++------------------- lib/ofp-util.def | 26 +- lib/ofp-util.h | 160 ++-- lib/packets.c | 14 +- lib/packets.h | 6 + ofproto/connmgr.c | 17 +- ofproto/fail-open.c | 14 +- ofproto/in-band.c | 12 +- ofproto/ofproto-dpif.c | 402 ++++---- ofproto/ofproto-provider.h | 39 +- ofproto/ofproto.c | 174 ++-- tests/learn.at | 4 +- tests/ofp-print.at | 6 +- tests/ovs-ofctl.at | 337 ++++++- tests/test-bundle.c | 55 +- tests/test-flows.c | 12 +- tests/test-multipath.c | 11 +- utilities/ovs-controller.c | 2 +- utilities/ovs-ofctl.8.in | 10 +- utilities/ovs-ofctl.c | 164 ++- 52 files changed, 5376 insertions(+), 3157 deletions(-) create mode 100644 lib/ofp-actions.c create mode 100644 lib/ofp-actions.h -- 1.7.2.5 _______________________________________________ dev mailing list dev@openvswitch.org http://openvswitch.org/mailman/listinfo/dev