On Tue, Jul 30, 2013 at 8:42 AM, <[email protected]> wrote: > Author: jpountz > Date: Tue Jul 30 12:42:39 2013 > New Revision: 1508423 > > URL: http://svn.apache.org/r1508423 > Log: > LUCENE-5145: AppendingPackedLongBuffer and added suport for bulk get > operations to the Appending*Buffers. > > Introduced bulk retrieval to AbstractAppendingLongBuffer > classes, for faster retrieval. Introduced a new variant, > AppendingPackedLongBuffer which solely relies on PackedInts as a backend. > This new class is useful where people have non-negative numbers with a > uniform distribution over a fixed (limited) range. Ex. facets ordinals. To > distinguish it from AppendingPackedLongBuffer, delta based > AppendingLongBuffer was renamed to AppendingDeltaPackedLongBuffer Fixed an > Issue with NullReader where it didn't respect it's valueCount in bulk gets. >
Do you think we should remove 'Long' from this class to help with the name? e.g. can it just be AppendingPackedBuffer? (or something shorter)
