-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/31967/#review76641
-----------------------------------------------------------


lgtm overall. Minor comments below.


core/src/test/scala/unit/kafka/server/ISRExpirationTest.scala
<https://reviews.apache.org/r/31967/#comment124277>

    should be not be -> can you fix/remove?



core/src/main/scala/kafka/cluster/Partition.scala
<https://reviews.apache.org/r/31967/#comment124224>

    Wonder why this got split. Can you re-optimize imports?



core/src/main/scala/kafka/cluster/Partition.scala
<https://reviews.apache.org/r/31967/#comment124225>

    Can you move the if statement to the next line



core/src/main/scala/kafka/cluster/Partition.scala
<https://reviews.apache.org/r/31967/#comment124243>

    Can we rename the argument to maxLagMs?



core/src/main/scala/kafka/cluster/Partition.scala
<https://reviews.apache.org/r/31967/#comment124245>

    Minor edit:
    "has not read up to the LEO within the last replicaMaxLag ms, then the 
follower is lagging and should be removed from the ISR"



core/src/main/scala/kafka/cluster/Partition.scala
<https://reviews.apache.org/r/31967/#comment124251>

    (Not part of your change, but could you change [%s,%d] to %s and replace 
topic, partitionId to TopicAndPartition(topic, partitionId)? We are trying to 
adopt a uniform convention everywhere in printing topic-partition and have been 
making these changes gradually (as they appear).



core/src/main/scala/kafka/cluster/Partition.scala
<https://reviews.apache.org/r/31967/#comment124252>

    same here



core/src/main/scala/kafka/cluster/Replica.scala
<https://reviews.apache.org/r/31967/#comment124256>

    Can you rename this to lagBeginTimeMsUnderlying?



core/src/main/scala/kafka/cluster/Replica.scala
<https://reviews.apache.org/r/31967/#comment124254>

    read up to the log end offset snapshot when the read was initiated ...



core/src/main/scala/kafka/server/ReplicaManager.scala
<https://reviews.apache.org/r/31967/#comment124260>

    Can we rename this to logEndOffsetBeforeRead?
    
    Also, can we just do with the Long (offset) instead of the entire 
LogOffsetMetadata?


- Joel Koshy


On March 16, 2015, 6:32 p.m., Aditya Auradkar wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/31967/
> -----------------------------------------------------------
> 
> (Updated March 16, 2015, 6:32 p.m.)
> 
> 
> Review request for kafka.
> 
> 
> Bugs: KAFKA-1546
>     https://issues.apache.org/jira/browse/KAFKA-1546
> 
> 
> Repository: kafka
> 
> 
> Description
> -------
> 
> PATCH for KAFKA-1546
> 
> Brief summary of changes:
> - Added a lagBegin metric inside Replica to track the lag in terms of time 
> since the replica did not read from the LEO
> - Using lag begin value in the check for ISR expand and shrink
> - Removed the max lag messages config since it is no longer necessary
> - Returning the initialLogEndOffset in LogReadResult corresponding to the the 
> LEO before actually reading from the log.
> - Unit test cases to test ISR shrinkage and expansion
> 
> Updated KAFKA-1546 patch to reflect Neha and Jun's comments
> 
> 
> Diffs
> -----
> 
>   core/src/main/scala/kafka/cluster/Partition.scala 
> c4bf48a801007ebe7497077d2018d6dffe1677d4 
>   core/src/main/scala/kafka/cluster/Replica.scala 
> bd13c20338ce3d73113224440e858a12814e5adb 
>   core/src/main/scala/kafka/log/Log.scala 
> 06b8ecc5d11a1acfbaf3c693c42bf3ce5b2cd86d 
>   core/src/main/scala/kafka/server/FetchDataInfo.scala 
> 26f278f9b75b1c9c83a720ca9ebd8ab812d19d39 
>   core/src/main/scala/kafka/server/KafkaConfig.scala 
> 48e33626695ad8a28b0018362ac225f11df94973 
>   core/src/main/scala/kafka/server/ReplicaManager.scala 
> c5274822c57bf3c1f9e4135c0bdcaa87ee50ce20 
>   core/src/test/scala/unit/kafka/server/ISRExpirationTest.scala 
> 92152358c95fa9178d71bd1c079af0a0bd8f1da8 
>   core/src/test/scala/unit/kafka/server/KafkaConfigConfigDefTest.scala 
> c124c8df5b5079e5ffbd0c4ea359562a66aaf317 
>   core/src/test/scala/unit/kafka/server/LogRecoveryTest.scala 
> 92d6b2c672f74cdd526f2e98da8f7fb3696a88e3 
>   core/src/test/scala/unit/kafka/server/SimpleFetchTest.scala 
> efb457334bd87e4c5b0dd2c66ae1995993cd0bc1 
> 
> Diff: https://reviews.apache.org/r/31967/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Aditya Auradkar
> 
>

Reply via email to