----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/28025/#review61964 -----------------------------------------------------------
Overall this looks good except for a naming suggestion and removal of comments. core/src/main/scala/kafka/javaapi/consumer/ConsumerRebalanceListener.java <https://reviews.apache.org/r/28025/#comment103884> * I think we can just combine this patch with the mirror maker improvements. * The comment itself can be removed and replaced with something more general. e.g., this call-back may be used when any batch-processing of messages is needed and offsets are committed after processing is complete. * Also, we should probably rename this to beforeReleasingPartitions or something like that. * Have you thought about how this effect will be achieved with the new consumer API and whether changes are needed there? - Joel Koshy On Nov. 18, 2014, 1:42 a.m., Jiangjie Qin wrote: > > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > https://reviews.apache.org/r/28025/ > ----------------------------------------------------------- > > (Updated Nov. 18, 2014, 1:42 a.m.) > > > Review request for kafka. > > > Bugs: KAFKA-345 > https://issues.apache.org/jira/browse/KAFKA-345 > > > Repository: kafka > > > Description > ------- > > Added new unit test. > > > Incorporated Joel's comments > > > Incorporated Joel's comments > > > Addressed Joel's comments. > > > Diffs > ----- > > core/src/main/scala/kafka/consumer/ZookeeperConsumerConnector.scala > f476973eeff653473a60c3ecf36e870e386536bc > core/src/main/scala/kafka/javaapi/consumer/ConsumerRebalanceListener.java > PRE-CREATION > core/src/main/scala/kafka/javaapi/consumer/ZookeeperConsumerConnector.scala > 1f98db5d692adc113189ec8c75a4fad29d6b6ffe > > core/src/test/scala/unit/kafka/consumer/ZookeeperConsumerConnectorTest.scala > e1d87112a2a587aa3a2f5875f278b276c32f45ac > > Diff: https://reviews.apache.org/r/28025/diff/ > > > Testing > ------- > > > Thanks, > > Jiangjie Qin > >