Hi Seung-chan, Thanks for the update. Making the default value to `Long.MAX_VALUE` of duration for consistency makes sense to me.
I have no more comments. Thank you. Luke On Sat, Feb 19, 2022 at 5:12 PM Seung-chan Ahn <dev.issea1...@gmail.com> wrote: > Hi Luke, > > Thanks for the comment. > > 3. In that case, I assumed we'd make it behave in the same way of > `close()`, and that eventually means the `close(Long.MAX_VALUE)`. It'd be > better to specify the default value in the `CloseOptions` class. Let me > update the KIP -> Done > > Thank you. > Seung-chan > > On Sat, Feb 19, 2022 at 4:42 PM Luke Chen <show...@gmail.com> wrote: > > > Hi Seung-chan, > > > > Thanks for the update. > > > > One more comment: > > 3. Could you explain if user doesn't provide the `timeout` value in > > `CloseOptions`. What will happen? I saw the default value for `timeout` > > variable in `CloseOptions` is `null`. What doest null `timeout` mean? > > > > Thank you. > > Luke > > > > On Sat, Feb 19, 2022 at 3:31 PM Seung-chan Ahn <dev.issea1...@gmail.com> > > wrote: > > > > > Hi Luke, > > > > > > Thanks for reviewing this KIP! > > > > > > 1. You are right, I'm only adding one method with `CloseOptions`. Let > me > > > comment in the KIP! -> Done > > > 2. I think it makes more sense to have `Duration` type option which is > > > aligned to the existing public method. Let me update the KIP! -> Done > > > > > > Seung-chan > > > > > > On Fri, Feb 18, 2022 at 3:21 PM Luke Chen <show...@gmail.com> wrote: > > > > > > > Hi Seung-chan, > > > > > > > > Thanks for the KIP! > > > > I like the optimization to have a close method to force leave group. > > > > Some minor comments: > > > > 1. in the "public interfaces", there are many `close` method listed, > > but > > > I > > > > believe you only want to introduce the one with `CloseOptions`, > right? > > > > Could you add some comment to it to point it out this is what you > added > > > in > > > > this KIP? > > > > 2. In the CloseOptions class variable, I saw there's a `timeoutMs` as > > > type > > > > `Integer`. Could you explain why we use `Integer` here, instead of > > `int`, > > > > or `Duration`? > > > > > > > > Thank you. > > > > Luke > > > > > > > > On Tue, Feb 15, 2022 at 11:19 PM Seung-chan Ahn < > > dev.issea1...@gmail.com > > > > > > > > wrote: > > > > > > > > > Hi Guozhang, > > > > > > > > > > > > > > > Thanks a lot for sharing your idea and guiding me. > > > > > > > > > > > > > > > Thanks to your support, we've reached this voting: > > > > > > > > > > https://lists.apache.org/thread/toq5pg799ctd7lwdcd6g7zk6xn73h26r > > > > > > > > > > > > > > > Seung-chan > > > > > > > > > > On Wed, Jan 12, 2022 at 10:50 PM Seung-chan Ahn < > > > dev.issea1...@gmail.com > > > > > > > > > > wrote: > > > > > > > > > > > Hi team, > > > > > > > > > > > > Here's the new KIP > > > > > > < > > > > > > > > > > > > > > > https://cwiki.apache.org/confluence/display/KAFKA/KIP-812%3A+Introduce+another+form+of+the+%60KafkaStreams.close%28%29%60+API+that+forces+the+member+to+leave+the+consumer+group > > > > > > > > > > > > for this issue < > https://issues.apache.org/jira/browse/KAFKA-13217 > > >. > > > > > > > > > > > > The title says pretty much what this KIP is for. Even though it's > > my > > > > > first > > > > > > draft, as A. Sophie Blee-Goldman has written rich descriptions > and > > > > > already > > > > > > the solutions in the issue thread, I've enjoyed following up on > the > > > > idea. > > > > > > > > > > > > Please feel free to review on any point! > > > > > > > > > > > > > > > > > > > > >